ls: cannot access NAS: Permission deneid [SOLUCIONADO]

Hacia ya unos meses que tenia el servidor en marcha y nunca me había pasado algo igual.

Tengo un NAS, un disco duro externo pero en vez de enchufarlo por USB a un equipo se enchufa con un cable de red RJ45 al router/switch/tarjeta de red.

Lo empleo para guardar una copia de seguridad incremental mediante imágenes del servidor.

Explicare brevemente lo que es una imagen de disco; en vez de guardar todos los archivos por separado se crea uno solo. Dicho archivo necesita de un software para ser generado, hay un montón en el mercado. Vale, tu empleas el WinRaR (con licencia xD) y el 7z, y guardas todos tus archivos importantes en uno único archivo… si! Ok! Pero aparte de que una imagen tenga varias ventajas, la mejor es la que llevo haciendo desde hace muchos años: Imagen completa separada en archivos de 4GB, y no explicare el porque, tal vez en un futuro, solo os diré una pista;

Disco 1 cargado satisfactoriamente, Inserte el disco 2 y pulse Aceptar para continuar…

Pues después de todo este royo, el NAS tiene un directorio que lo comparto en NFS (no explicare lo que es, bueno os diré una pista: Wiki).

Volviendo al error, cuyo error me enteré por un mail que me mando el servidor (proxmox, muy moderno todo xD):

Asunto: ***** --quiet 1 --mode snapshot --mailto [email protected] --node *NODE* --compress gzip --storage NAS Texto: unable to activate storage 'NAS' - directory '/mnt/XXX/NAS' does not exist
Por algún motivo he tenido algún error que no se cual es y que en la consola del servidor al realizar un:
ls
en el directorio donde estaba montado mi NAS me aparecían interrogantes. Una cosa bastante rara.

También comprobé que el NAS funcionaba xD.

He reiniciado el servidor, lamentablemente es el TRUNK y no uno virtual:

shutdown -r now
Después de reiniciar (1 minuto) ya me aparecía bien los permisos del directorio y ya empezó ha realizar la copia de seguridad.

Que sudores frios!

Show Comments