Vulnerabilidad en bash (CVE-2014-6271) Shellshock

Para todos aquellos que administren sistemas Linux se les recomienda que actualicen “bash” a su ultima versión.

Para saber si tu sistema es vulnerable prueba esta linea en la terminal de tu máquina:

env x='() { :;}; echo vulnerable' bash -c "echo this is a test"

Si tu resultado es el siguiente:

vulnerable this is a test

TU MÁQUINA ES VULNERABLE ACTUALIZA!

Para arreglar este problema ejecuta lo siguiente:

apt-get update

apt-get install --only-upgrade bash

Un vez actualizado prueba de nuevo el comando que he escrito arriba.

Si el resultado es el siguiente:

bash: warning: x: ignoring function definition attempt bash: error importing function definition for `x' this is a test

Ya has arreglado el problema!

Ahora, a tomarse un café!

😉

PD: Mi máquina es un SO Proxmox basado en Debian. PD2: Por cierto, pruebalo en tu mac, seguro que tambien es vulnerable ^^. PD3: No es una solucion publicada por debian.

Información obtenida desde:

No me hago responsable de los daños ocasionados con este tutorial

Show Comments